728x90

문제 설명   

어떤 숫자가 입력되면 그 숫자가 몇 자릿수 숫자인지 알아내는 프로그램을 작성하시오.

예)

7   ----> 1   (1자릿수)

10  ----> 2   (2자릿수)

4322 ----> 4   (4자릿수)

 

입력

 

1이상의 자연수 n이 입력된다. (n은 int 범위)

 

출력

 

그 숫자가 몇 자릿수 인지 출력하시오.

 

입력 예시

 

932

 

출력 예시

 

3

 

#include <iostream>
#include <string>
using namespace std;

int main()
{
	string str;
	cin >> str;
	cout << str.size() << endl;
}

 

입력 되는 숫자를 정수형으로 받지않고 string 문자열로 받아서 size를 계산하는 방식으로 구현했습니다.

 

정수형으로 받아서 직접 자릿수를 구하는 방법도 있겠네요

 

#include <stdio.h>

int main()
{
	int n, cnt = 0;
	scanf("%d", &n);
	while( n > 0 ) {
		n = n /10;
		cnt++;
	}
	printf("%d", cnt);
	return 0;
}

 

728x90